• Hail Guest!
    We're looking for Community Content Contribuitors to Stratics. If you would like to write articles, fan fiction, do guild or shard event recaps, it's simple. Find out how in this thread: Community Contributions
  • Greetings Guest, Having Login Issues? Check this thread!
  • Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
  • Hail Guest!
    Please read the new announcement concerning the upcoming addition to Stratics. You can find the announcement Here!

General Patch Issue on Install


Stratics Veteran
Hi, I am having issues logging into Ultima Online. I start the download from uo.com and when it gets finished it always kicks back a patch error. Always the same patch error. I have tried both clients. I have deleted completely and retried both multiple times. I have reset my laptop to factory settings and tried and still nothing. I have tried to run in an older windows and that did not work. I have ran every attempt as administrator. I've gone into the files and tried to run patch.exe from inside the program files. I have been trying to get on for two days and it is the same error over and over. I have attached a photo of the error message I recieve. I am running windows 8.1 on a lenovo laptop, corei7 processor, nvidia geforce gtx graphics card. Thanks for any help you maybe able to offer. I have contacted EA but they keep sending me the same generic "Delete all files and download from uo.com" and I keep telling them that I have done that in every email to them. @Bleak @Kyronix

Also here is the link to my post on general thread if it is of any importance.



Lord Gandalf

Crazed Zealot
Stratics Veteran
Stratics Legend
Did u make sure u dont have any packets loss problems? To test this go to cmd and try to ping some random servers. Ex: ping (address) -t

This could be an ISP problem