• Hail Guest!
    We're looking for Community Content Contribuitors to Stratics. If you would like to write articles, fan fiction, do guild or shard event recaps, it's simple. Find out how in this thread: Community Contributions
  • Greetings Guest, Having Login Issues? Check this thread!
  • Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
  • Hail Guest!
    Please read the new anncouncement concering the upcoming addition to Stratics. You can find the annoucnement Here!

[BUG] !!! List of current Enhanced Client bugs !!!

Status
Not open for further replies.

lucitus

UOEC Modder
Stratics Veteran
Stratics Legend
I know the macro you are talking about, i have used it also with my mage in KR and it worked fine. But i havent played my mage for a long time now, i have to test it.

You have set Heal > Target Self or? Are you clicking or using it over a hotkey?

With KR there were no problems with it i rember i were hammering on this key sometimes ;)

Maybe it is a result of the new delay settings, but i have to test it ;)
 

Llewen

Grand Inquisitor
Stratics Veteran
Stratics Legend
Campaign Supporter
I know the macro you are talking about, i have used it also with my mage in KR and it worked fine. But i havent played my mage for a long time now, i have to test it.

You have set Heal > Target Self or? Are you clicking or using it over a hotkey?

With KR there were no problems with it i rember i were hammering on this key sometimes ;)

Maybe it is a result of the new delay settings, but i have to test it ;)
I use it on a hot bar, so I am clicking it. What specifically I have had a problem with is the heal spell set to self for the target. It wasn't a macro. I've switched to a macro, which is essentially the same thing, but because it is a macro it might not have the same problem. I'll post when I've had a chance to play with it.

The thing is that 90% of the time it has worked flawlessly, and I don't think I've noticed any issues in pvm, although I couldn't swear on that. It just seems to stop working when I need it most in pvp specifically, which would mean that I am doing a lot of button mashing and moving around a lot.

I'm wondering if it could be another movement issue, related to my use of the joystick on my G13 for movement. I had severe problems with that until I switched my macros from ctrl-shift to alt-shift (mouse follow movement, running in a given direction and not being able to stop). I still do have some problems, but nowhere near what I used to.
 

Llewen

Grand Inquisitor
Stratics Veteran
Stratics Legend
Campaign Supporter
Well so far it appears to that changing from the spell being dragged directly to the hotbar, to an actual macro that I placed on the hotbar, has made a difference. It hasn't stopped working since I made that change. I'll report back if it screws up again.
 

Llewen

Grand Inquisitor
Stratics Veteran
Stratics Legend
Campaign Supporter
I have another great one that is really starting to **** me off. I have heal on a hot bar with target set to self. When I'm in trouble I click on that like mad. Well for some reason it will just stop working.
I've figured out what the problem is. It's a bug that I knew about, but I had forgotten about. When there is text on the screen it displays in front of the icons and it blocks the icons from being used, so obviously the more text there is on the screen, the more chance there is that the icons will stop working.

I'm not quite sure what to do about this because I have icons all over my screen. Hopefully this one will be noticed and fixed. It has gotten me killed many times.
 

lucitus

UOEC Modder
Stratics Veteran
Stratics Legend
I have another great one that is really starting to **** me off. I have heal on a hot bar with target set to self. When I'm in trouble I click on that like mad. Well for some reason it will just stop working./QUOTE]

I've figured out what the problem is. It's a bug that I knew about, but I had forgotten about. When their is text on the screen it displays in front of the icons and it blocks the icons from being used, so obviously the more text there is on the screen, the more chance there is that the icons will stop working.

I'm not quite sure what to do about this because I have icons all over my screen. Hopefully this one will be noticed and fixed. It has gotten me killed many times.
Ohh yeah, the chatwindow has an incorrect layer at the moment, it should be background but it is in the same "normal" layer than the other interface elements, it would be great to see a fix here.
 

Hildebrand

Certifiable
Stratics Veteran
Stratics Legend
I totally forgot this bug. Confusion blast and Invis potions if both carried, will add up as one item in your hotbar. Then when using your macro for confusion blast, it will use one or the other as if they were the same. Example... i have 2 Greater confusion pots on my hotbar. If I add one invis pot, then I will see total of 3 Gr Confusion in the hotbar. If I hit my macro, I "might" use the confusion... then if I use the same macro again... it will drink the invis pot.
I therefore don't carry both since it's broke and unreliable.
 

lucitus

UOEC Modder
Stratics Veteran
Stratics Legend
I totally forgot this bug. Confusion blast and Invis potions if both carried, will add up as one item in your hotbar. Then when using your macro for confusion blast, it will use one or the other as if they were the same. Example... i have 2 Greater confusion pots on my hotbar. If I add one invis pot, then I will see total of 3 Gr Confusion in the hotbar. If I hit my macro, I "might" use the confusion... then if I use the same macro again... it will drink the invis pot.
I therefore don't carry both since it's broke and unreliable.
Ohh yeah this is a long time bug!
 

Hildebrand

Certifiable
Stratics Veteran
Stratics Legend
A hotkey to show all names on the screen would be handy. (recently added)

There is a way to show all names on the screen. It's in the Options where the default keys are. I assigned Right-Alt-N. Works perfectly.
 

Cear Dallben Dragon

Babbling Loonie
Stratics Veteran
Stratics Legend
UNLEASHED
So boy, how about that not being able to use the client in fel whatsoever that effects hundreds of people. that 2 fps thing, that sure is getting.....old.:sad4:
 

MalagAste

Belaern d'Zhaunil
Alumni
Stratics Veteran
Stratics Legend
UNLEASHED
Campaign Supporter
Ok so I think I read through this whole thing and I have a few things to add....

1) There is NO way to specify what form you turn into with Animal form in a macro..... there should be as in 2d with UO Assist you can pretty much tell the game you want to change to ostard form or dog form or whatever you want to set up..... we need to be able to do this in the EC.

2) The stuff anything that is "animated" is still blinking, blinking, blinking..... driving me insane.....

3) The crummy circle of transparency makes the bandage fountains INVISIBLE.... Not cool! They should not vanish.... they are a container... of sorts.

4) As an archer I'm down fighting the slasher and it occurs to me that I can't see my bow! My character is firing an invisible bow... it's on my paperdoll..... but while I'm watching my character.... he seems to be using an invisible bow...

5)Consecrate weapon.... now in the 2d client the graphic of the weapon being consecrated is the same as the weapon you are holding.... however in the EC it's always a sword despite the fact that I carry a bow.... Or a mace... it's still a sword.... not that I'm overly picky.... just saying.

6)..... WHY after so long am I still seeing the fires from my candelabra of souls on the floor above them???? Makes it look like my castle is burning down.

7)WHEN are we going to get the housing gump from the KR client??? PLEASE!!!! I'm sick and tired of being relegated to friend status at my house's again.. I want to be the co-owner again.... to all my homes..... with ALL my characters....

Cal..... me patience is wearin thin...

oh... and Feedback is a good thing... we could use more of it.
 

hawkeye_pike

Babbling Loonie
Stratics Veteran
Stratics Legend
I just updated the buglist according to the recent publish. Any other issues that were solved? Do gloves and sleeves still become invisible? I couldn't reproduce it anymore after the publish, but I want to be sure.

Did anyone fight the Slasher of Veils after the patch? Do its field spells still cause the client to slow down or crash?
 

lucitus

UOEC Modder
Stratics Veteran
Stratics Legend
I just updated the buglist according to the recent publish. Any other issues that were solved? Do gloves and sleeves still become invisible? I couldn't reproduce it anymore after the publish, but I want to be sure.
No it isnt fixed, simple reproduce is to open the paperdoll or a container containing the items described and then open the item insurance menu, the items are also broken in the menu and after doing that they should become invisble while dragged.

Sorry but i cannot reproduce the invisble bug anymore. Seems to be fixed but i cannot say it 100%.
 

hawkeye_pike

Babbling Loonie
Stratics Veteran
Stratics Legend
Large numbers of particle effects or many field spells (or the nova spell of certain boss monsters like Crimson Dragon) cause memory leaks at the graphics adapter. This causes heavy lag (screen freezes for 30s-1 min), and after some time the client will crash.
2 days ago I fought the Slasher of Veils again, after a long time. What came to my attention was that I did not have to restart the client one time during that 40-minute fight, while before last patch it required at least 3 client restarts due to increasing lag that made UO unplayable. At the end of the fight the client was still slower than at the beginning, but it was still playable.

I don't want to count chicken before they hatch, but I would say that the memory leak effect has been lessened somewhat. It still is not solved though.

Can anyone else confirm?

P.S.: The disappearing armor still happens.
 

Pinco

UOEC Modder
Stratics Veteran
Stratics Legend
Here is some other bugs:

- Veteran rewards ankh (the one who resurrect you) has the blood visible in every floor of the house
- when you use ctrl+shift you cant bring up a label by clicking it (like in 2d)
- when you die there is a big delay before to see something
- the targeting problem with energy vortex: same with colossus and revenant
- generally the items on the ground (but much more the items with backpack in legacy mode) are darker than 2d.
- the damage overhead is too slow (or too fast, depends on resolution). A slide bar for control it is required...
- the damage overhead goes too high (as the speed depends on resolution). A slide bar for this would be nice too.
- blood is an object visible with ctrl+shift and this is a really bad thing...
- Sometimes I cannot use my castle doors, when I click them it says: "Stone Wall" and I have to use the opendoor macro.

suggestions:
- I think that will be great to have a macro for hide looted corpses (maybe a button in the corpse container). This will allow you to hide it (only for yourself, the others shall see it) and will help a lot with looting...
 

Llewen

Grand Inquisitor
Stratics Veteran
Stratics Legend
Campaign Supporter
At the end of the fight the client was still slower than at the beginning, but it was still playable.

I don't want to count chicken before they hatch, but I would say that the memory leak effect has been lessened somewhat. It still is not solved though.

Can anyone else confirm?
I'm seeing this. I'm still experiencing lowered performance over time, but I don't think it is as bad as it used to be.
 

Cear Dallben Dragon

Babbling Loonie
Stratics Veteran
Stratics Legend
UNLEASHED
Party chat now cuts off the last letter of your name
I was not able to access a rune book via hot bar while in party
Loging in and out really quick kicked my from party instead of re-joining.
:(
 

Martyna Zmuir

Crazed Zealot
Stratics Veteran
Stratics Legend
The nova blast / treasure guardian explosion (that the EMs use) desperately needs to be fixed. This memory leak makes fighting in the Abyss a nightmare (its also ruining EM events)


Mythic said this would be fixed last November. Time to live up to the promise.
 

lucitus

UOEC Modder
Stratics Veteran
Stratics Legend
The nova blast / treasure guardian explosion (that the EMs use) desperately needs to be fixed. This memory leak makes fighting in the Abyss a nightmare (its also ruining EM events)


Mythic said this would be fixed last November. Time to live up to the promise.
I dont understand everybody is talking about a memory leak? It is normal that a game is getting slower as longer it runs. It is true that there is a lag problem in felucca and it is true that there is a problem with many effects on the screen for example fire elemental corpses, but when you not in the screen of those the problem is over again. So this is for my definition no memory leak, you can say the effects are using too much memory and cpu power, memory i dont see but cpu is right. I think it has something todo with the graphics engine it fails to use the graphics card right, maybe it is a result of the agreement between low end pcs and a 3d engine.

But is is interesting here what the Devs can tell us, why are some effects so laggy, while the game itself runs smooth also on highend machines?
 

Martyna Zmuir

Crazed Zealot
Stratics Veteran
Stratics Legend
Lucitus,

Go fight the Slasher, you WILL encounter the problem (it may take a few fights with him for it to happen though, it seems random). He has several effects which can bring the client to its knees, and it cannot recover from them at times.
 

hawkeye_pike

Babbling Loonie
Stratics Veteran
Stratics Legend
I dont understand everybody is talking about a memory leak? It is normal that a game is getting slower as longer it runs. It is true that there is a lag problem in felucca and it is true that there is a problem with many effects on the screen for example fire elemental corpses, but when you not in the screen of those the problem is over again. So this is for my definition no memory leak, you can say the effects are using too much memory and cpu power, memory i dont see but cpu is right. I think it has something todo with the graphics engine it fails to use the graphics card right, maybe it is a result of the agreement between low end pcs and a 3d engine.
Memory leak means, some parts of the software take up some memory and don't release it anymore when they are finished. This causes more and more memory to be allocated, causing the graphics adapter to run out of memory. This causes massive lag that only can be solved by closing the whole software (i.e. the Enhanced Client).

It is not normal for a game to run slower over time, if it is programmed correctly. In the case of the EC, the client literally breaks down within 10 minutes if certain particle effects occur on your screen. If you have a graphics adapter with more memory, it will probably take longer to crash.

I use a 512 MB graphics adapter. While I don't have any noteworthy lag in game, usually I had to restart the client 3 or 4 times during a Slasher fight. Since the latest patch, I don't have to restart anymore, but I still notice abnormal increasing lag during this battle. I now have to restart the client only 1 time (at the end of the battle). Thus, the problem seems to be less severe now, but it still is there.

The lag you experience when moving the mouse over the black part of the screen (I could not reproduce that) is most likely a different issue.
 

R Traveler

Crazed Zealot
Stratics Veteran
Stratics Legend
Since only THIS thread in devs bookmarks, one more crosspost :bdh:



Its best what I can fine tune using camerazoom and window size. Look at green good areas and red misaligned.

My guess its because some rounding math do not uses current zoom settings.

Can we have fixed 1:1 setting to make picture better?
 

BTeng_Mythic

UO Legend
VIP
Stratics Veteran
Stratics Legend
Already read in the other thread and noted.

As for the fixed 1:1 camera setting, there's no fixed value that can be used because the value is different for all resolutions. The next best thing at the moment is to have the zoom setting preserved across play sessions, which is currently does now.
 

Hildebrand

Certifiable
Stratics Veteran
Stratics Legend
Party chat will now cut off the last letter in your name.
Is it because of a really long name? Is anyone else encountering this? I don't see this happening on my end.
Happens to me too. It chops last letter no matter how long the name is. This happened after the name title thing went in. Like Hildebrand the Necromancer... would chop the "r" in party chat if I remember correctly. Even chops off if the person doesn't have a title. Example: Lilly would display Lill.
I prefer to not have the titles in the chat anyway since it takes up more room.
 

R Traveler

Crazed Zealot
Stratics Veteran
Stratics Legend
Already read in the other thread and noted.

As for the fixed 1:1 camera setting, there's no fixed value that can be used because the value is different for all resolutions. The next best thing at the moment is to have the zoom setting preserved across play sessions, which is currently does now.
Not sure why my reply lost... can you save one more digit after decimal point to store values like 16.486
 

Llewen

Grand Inquisitor
Stratics Veteran
Stratics Legend
Campaign Supporter
Party chat will now cut off the last letter in your name.
Is it because of a really long name? Is anyone else encountering this? I don't see this happening on my end.
Happens to me too. It chops last letter no matter how long the name is. This happened after the name title thing went in. Like Hildebrand the Necromancer... would chop the "r" in party chat if I remember correctly. Even chops off if the person doesn't have a title. Example: Lilly would display Lill.
I prefer to not have the titles in the chat anyway since it takes up more room.
Speaking of chat problems. I'm still having problems with the last few lines of chat being chopped off. It isn't perfectly consistent. It seems the longer I have been playing the more likely it is to happen. I will have to do something like lore myself to see the last few lines of chat if I missed them on screen.
 

Cear Dallben Dragon

Babbling Loonie
Stratics Veteran
Stratics Legend
UNLEASHED
Something is wrong with delays in general. I stood perfectly still and used my macro to drink a str and agil pot 17 times.

6 of those times the macro stopped after the str pot and said i needed to wait to preform another action.

edit: fyi, the delay btw the two is 2.2

.....
 

R Traveler

Crazed Zealot
Stratics Veteran
Stratics Legend
One more question - is there any command like
Code:
/script CameraZoom = 16.00
to adjust this setting on fly or from script?
 

Dermott of LS

UOEC Modder
Stratics Veteran
Stratics Legend
...

Something is wrong with delays in general. I stood perfectly still and used my macro to drink a str and agil pot 17 times.

6 of those times the macro stopped after the str pot and said i needed to wait to preform another action.

edit: fyi, the delay btw the two is 2.2


This seems to be the same thing taht affects my smelt-all portion of my mining macro. Before a couple of patches ago (that changed the delay system), the smelt portion would smelt every present ore type and size. Now it smelts the first one it encounters then skips the rest and starts the macro over again.
 

lucitus

UOEC Modder
Stratics Veteran
Stratics Legend
Memory leak means, some parts of the software take up some memory and don't release it anymore when they are finished. This causes more and more memory to be allocated, causing the graphics adapter to run out of memory. This causes massive lag that only can be solved by closing the whole software (i.e. the Enhanced Client).

It is not normal for a game to run slower over time, if it is programmed correctly. In the case of the EC, the client literally breaks down within 10 minutes if certain particle effects occur on your screen. If you have a graphics adapter with more memory, it will probably take longer to crash.

I use a 512 MB graphics adapter. While I don't have any noteworthy lag in game, usually I had to restart the client 3 or 4 times during a Slasher fight. Since the latest patch, I don't have to restart anymore, but I still notice abnormal increasing lag during this battle. I now have to restart the client only 1 time (at the end of the battle). Thus, the problem seems to be less severe now, but it still is there.

The lag you experience when moving the mouse over the black part of the screen (I could not reproduce that) is most likely a different issue.
First you load things you need into the memory, but deleting it instalty may cause many problems, think of rejoining the same area, you have to load all textures again from the harddrive, this is slow. In Half Life for example you have a good system of level loading for this, when you enter a new area old stuff will be removed and new stuff is loaded in, this needs time, but is no problem for the half life engine because there are loading screens. In UO it isnt possible so easy, because you have no loading screens or teleport loading screens, so you have todo it at the same time and this costs power looking for what to delete, is like looking into a table at each entry and decide if it should be removed or not and if even one entry is deleted wrong it happend what happend in KR many times it crashes.

I dont want to negate your problem, maybe there is a leak in the animation system but not for me! I have done many slashers and only for one i can report a bug, the client slows down at 3 fps and stucks there a relogin corrects it.

But it can also be possible that it is a hardware specific problem, maybe that such a cleaning function is not working correctly for your machine, too fast for example or too slow and then it happens that you got such strange performance lost.

Lets compare the hardware, i have:
Intel Q6600
4 GB Ram
ATI HD 4890 - 1024 MB
1 TB Harddiskspace (RAID 0, no SSD)
ASUS P5Q Mobo
Windows 7 x64

Have you tried to reduce or raise the cache in the settings? Again i want to help not to critize you!
 

Dermott of LS

UOEC Modder
Stratics Veteran
Stratics Legend
...

I don't want to say this prematurely, but I THINK they may have fixed the You Cannot Pick That Up bug that's been plaguing the EC for a LONG time with the last patch.
 

lucitus

UOEC Modder
Stratics Veteran
Stratics Legend
Evil omen has been on my debuff display for a little over a day now.
Yes next thing the Devs have todo is to redesign the buff system, constant serverupdates and not transfering any **** over this buffid 15 for example.

I have fixed the buffsystem in my interface filtering all buffs which have no timer on them expect from the real ones without timer.

A clumsy without timer or evil omen is a false positive buff, i dont know why it is transfered from the server i think because of serverline switching while the bug was active.

Only thing what fixes it is to rebuff your character with the specific buff and then remove it when it is active. But how i said in my Interface a filter is intigrated which eliminates the wrong buffs when transfered from the server.
 

lucitus

UOEC Modder
Stratics Veteran
Stratics Legend
Two new bugs i have found out and confirmed:

  • The paperdoll closes when a player enters or reenters the party.
  • When you dismount and mount up again, the bag closes. After this the runebooks in the hotbars are greyed out and unusable.
 

lucitus

UOEC Modder
Stratics Veteran
Stratics Legend
Already read in the other thread and noted.

As for the fixed 1:1 camera setting, there's no fixed value that can be used because the value is different for all resolutions. The next best thing at the moment is to have the zoom setting preserved across play sessions, which is currently does now.
Hehe you are funny Bteng, isnt there a formular to calculate the zoomlevel for all resolutions?

Is it not possible to intigrate it easiely to the system as default value?

But other things are good work so far! You are on the right way, when the client is finished we will make a party for you and the other hard working Devs ;)
 

BTeng_Mythic

UO Legend
VIP
Stratics Veteran
Stratics Legend
Two new bugs i have found out and confirmed:

  • The paperdoll closes when a player enters or reenters the party.
  • When you dismount and mount up again, the bag closes. After this the runebooks in the hotbars are greyed out and unusable.
The first issue will be fixed in the next patch.

As for the second issue, which mount are you using? And are you talking about your main backpack? I've tried the internal builds of the client, as well as the current version you guys are using and I'm not seeing any problems.
 

lucitus

UOEC Modder
Stratics Veteran
Stratics Legend
The first issue will be fixed in the next patch.

As for the second issue, which mount are you using? And are you talking about your main backpack? I've tried the internal builds of the client, as well as the current version you guys are using and I'm not seeing any problems.
Ahh okay i could reproduce it better now, you dismount, close the backpack, you open it again and use your etheral dropped in the hotbar to mount up, then the backpack closes and all things in the hotbars are greyed out, after opening the backpack all things are recounted expect the runebooks.
 
Status
Not open for further replies.
Top