• Hail Guest!
    We're looking for Community Content Contribuitors to Stratics. If you would like to write articles, fan fiction, do guild or shard event recaps, it's simple. Find out how in this thread: Community Contributions
  • Greetings Guest, Having Login Issues? Check this thread!
  • Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
  • Hail Guest!
    Please read the new announcement concerning the upcoming addition to Stratics. You can find the announcement Here!

[BUG] Can't place house on TC1, what's going on?



The house placement tool on TC1 seems busted. When I double click it in Trammel or Fellucia, nothing happens. No error, no message, no Gump pops up.

When I click it in Ter Mur, it tells me I must have enough loyalty to place a house. This lead me to think that something is "disqualifying" me from trying to place in Trammel or Fel. Yet there is no error message stating the fact - the gump simply doesn't open.

I tried buying a new tool. I tried relogging. I tried using a different, 1+ month old TC1 character to place. Still nothing worked.

So I got to googling and read about housing placement gates. Ran around looking for one in New Haven and Britain and could not find it. They are either hidden or don't seem to exist any more?

I own a house on a production shard, but wouldn't it give me an error message along the lines of 'you own too many houses' if that was preventing me from doing so?

So what the heck gives?

Thanks for any info...


helllllppppp meeeeee :p

has anyone placed a house on tc? if so, did you have a house on production also, or is your tc house your ONLY house on the acct?

Felonious Monk

Stratics Veteran
Stratics Legend
Hey guys I was having the same trouble Yesterday (6-10-10).
I was able to place with a 2 day old chr. No tricks no adjustments.
Click the placement tool provided in bank. It works now.